Upgrading WordPress to 2.5

According to Stuart Herbert, if you use the advanced TinyMCE editor instead of the builtin wysiwyg editor, disable it before upgrading. Its not compatible with 2.5 (yet).

On the other hand, always disable all plugins before upgrading, and enable them one by one afterwards.

And, Bjørge, I will get back to what I did to make WP-upgrading easy soon.